目的

Androidアプリを作る時にAPIレベルをいくつにすれば良いかのメモ

参照サイト

Google Developers

GoogleによるAPIレベルの要件

上記の参照サイトより

2019 年 8 月: API レベル 26 以上をターゲットにしていない新しいアプリをインストールしようとすると、警告が表示されます。
2019 年 11 月: 既存アプリの新規バージョンで、API レベル 26 以上をターゲットにしていないものをインストールしようとすると、警告が表示されます。
2020 年以降: ターゲット API レベル要件は毎年上がります。

ということで、少なくともAPIレベルは26以上にする必要があるようです。

minSdkVersion 26
アプリが実行できる最小バージョンで、これ以下だとインストール不可。

APIレベル26というと、Android 8.0(Oreo) 端末。

簡易ですが、以上です。